Packages Json

Packages Used

1
{
2
"name": "Enatega Rider",
3
"version": "5.0.1",
4
"main": "node_modules/expo/AppEntry.js",
5
"scripts": {
6
"start": "expo start",
7
"android": "expo start --android",
8
"ios": "expo start --ios",
9
"eject": "expo eject",
10
"format": "prettier --write '**/*.js'",
11
"lint:fix": "eslint . --ext .js --fix"
12
},
13
"husky": {
14
"hooks": {
15
"pre-commit": "lint-staged"
16
}
17
},
18
"lint-staged": {
19
"*.js": [
20
"npm run format",
21
"npm run lint:fix"
22
]
23
},
24
"dependencies": {
25
"@apollo/react-hooks": "^3.1.3",
26
"@expo/vector-icons": "^10.0.0",
27
"@react-native-community/masked-view": "0.1.10",
28
"@react-navigation/bottom-tabs": "^5.5.2",
29
"@react-navigation/drawer": "^5.8.2",
30
"@react-navigation/native": "^5.5.1",
31
"@react-navigation/stack": "^5.5.1",
32
"apollo-boost": "^0.4.3",
33
"apollo-cache-inmemory": "^1.6.2",
34
"apollo-client": "^2.6.3",
35
"apollo-link": "^1.2.12",
36
"apollo-link-context": "^1.0.18",
37
"apollo-link-state": "^0.4.2",
38
"apollo-link-ws": "^1.0.20",
39
"apollo-upload-client": "^10.0.1",
40
"expo": "^38.0.8",
41
"expo-constants": "~9.1.1",
42
"expo-font": "~8.2.1",
43
"expo-localization": "~8.2.1",
44
"expo-location": "~8.2.1",
45
"expo-permissions": "~9.0.1",
46
"expo-splash-screen": "^0.3.1",
47
"expo-task-manager": "~8.3.0",
48
"graphql": "^14.3.1",
49
"graphql-tag": "^2.10.1",
50
"i18n-js": "^3.3.0",
51
"react": "16.11.0",
52
"react-apollo": "^2.5.8",
53
"react-native": "https://github.com/expo/react-native/archive/sdk-38.0.0.tar.gz",
54
"react-native-animatable": "^1.3.2",
55
"react-native-flash-message": "^0.1.13",
56
"react-native-gesture-handler": "~1.6.0",
57
"react-native-maps": "0.27.1",
58
"react-native-maps-directions": "^1.8.0",
59
"react-native-material-textfield": "github:n4kz/react-native-material-textfield#pull/283/head",
60
"react-native-modal": "^11.5.6",
61
"react-native-reanimated": "~1.9.0",
62
"react-native-safe-area-context": "~3.0.7",
63
"react-native-screens": "~2.9.0",
64
"react-native-webview": "9.4.0",
65
"subscriptions-transport-ws": "^0.9.16"
66
},
67
"devDependencies": {
68
"babel-preset-expo": "^8.2.3",
69
"eslint": "^7.1.0",
70
"eslint-config-standard": "^14.1.1",
71
"eslint-plugin-import": "^2.20.2",
72
"eslint-plugin-node": "^11.1.0",
73
"eslint-plugin-promise": "^4.2.1",
74
"eslint-plugin-react": "^7.20.0",
75
"eslint-plugin-standard": "^4.0.1",
76
"husky": "^4.2.5",
77
"lint-staged": "^10.2.7",
78
"prettier": "2.0.5",
79
"prettier-config-standard": "^1.0.1"
80
},
81
"private": true
82
}
83
84
85
86
87
Copied!
Copy link