Packages Json

Packages Used

1
{
2
"name": "enatega-dashboard",
3
"version": "5.0.1",
4
"description": "Enatega dashboard",
5
"main": "index.js",
6
"homepage": "https://enatega.com/dashboard",
7
"scripts": {
8
"start": "react-scripts start",
9
"build": "react-scripts build",
10
"test": "react-scripts test",
11
"eject": "react-scripts eject",
12
"install:clean": "rm -rf node_modules/ && rm -rf package-lock.json && npm install && npm start",
13
"compile-sass": "node-sass src/assets/scss/argon-dashboard-react.scss src/assets/css/argon-dashboard-react.css",
14
"minify-sass": "node-sass src/assets/scss/argon-dashboard-react.scss src/assets/css/argon-dashboard-react.min.css --output-style compressed",
15
"map-sass": "node-sass src/assets/scss/argon-dashboard-react.scss src/assets/css/argon-dashboard-react.css --source-map true",
16
"lint:fix": "eslint . --ext .js,.jsx --fix",
17
"format": "prettier --write '**/*.{js,jsx}'"
18
},
19
"husky": {
20
"hooks": {
21
"pre-commit": "lint-staged"
22
}
23
},
24
"lint-staged": {
25
"*.js": [
26
"npm run format",
27
"npm run lint:fix"
28
]
29
},
30
"browserslist": [
31
">0.2%",
32
"not dead",
33
"not ie <= 11",
34
"not op_mini all"
35
],
36
"dependencies": {
37
"apollo-boost": "^0.3.1",
38
"apollo-link-ws": "^1.0.19",
39
"apollo-upload-client": "^10.0.0",
40
"chart.js": "2.7.3",
41
"classnames": "2.2.6",
42
"firebase": "^7.14.2",
43
"graphql": "^14.2.1",
44
"i18next": "^15.1.3",
45
"i18next-browser-languagedetector": "^3.0.1",
46
"lodash.orderby": "^4.6.0",
47
"moment": "2.24.0",
48
"node-sass": "^4.12.0",
49
"nouislider": "13.1.1",
50
"react": "16.8.4",
51
"react-apollo": "^2.5.4",
52
"react-bootstrap-typeahead": "^3.4.5",
53
"react-chartjs-2": "2.7.4",
54
"react-copy-to-clipboard": "5.0.1",
55
"react-data-table-component": "6.9.0",
56
"react-datetime": "2.16.3",
57
"react-dom": "16.8.4",
58
"react-google-maps": "9.4.5",
59
"react-i18next": "^10.10.0",
60
"react-loader-spinner": "3.1.14",
61
"react-router-dom": "4.3.1",
62
"react-scripts": "2.1.8",
63
"reactstrap": "7.1.0",
64
"styled-components": "5.1.0",
65
"subscriptions-transport-ws": "^0.9.16",
66
"validate.js": "^0.12.0"
67
},
68
"devDependencies": {
69
"@types/googlemaps": "3.30.18",
70
"@types/markerclustererplus": "2.1.33",
71
"@types/react": "16.8.7",
72
"typescript": "3.3.3333",
73
"eslint": "^7.1.0",
74
"eslint-config-standard": "^14.1.1",
75
"eslint-plugin-import": "^2.20.2",
76
"eslint-plugin-node": "^11.1.0",
77
"eslint-plugin-promise": "^4.2.1",
78
"eslint-plugin-react": "^7.20.0",
79
"eslint-plugin-standard": "^4.0.1",
80
"husky": "^4.2.5",
81
"lint-staged": "^10.2.7",
82
"prettier": "2.0.5",
83
"prettier-config-standard": "^1.0.1"
84
}
85
}
86
87
88
Copied!
Copy link